欢迎访问牛股网

牛股网

当前位置:牛股网 >股票知识 >

股票知识

「通达信」波峰波谷黄金分割主图指标公式

发布时间:2021-10-21 19:27 作者:牛股网
N:=34;{你随意调整N的参数,看看效果如何:你可以发现更多级别的阻力和支撑点}高:IF(HIGH>PEAK(1,N,1),HHV(HIGH,N),PEAK(1,N,1)),COLORGREEN;{最高价}低:IF(LOWF0.19…...

N:=34;{你随意调整N的参数,看看效果如何:你可以发现更多级别的阻力和支撑点}

高:IF (HIGH>PEAK(1,N,1),HHV(HIGH,N),PEAK(1,N,1)),COLORGREEN;{最高价}

低:IF (LOWF0.191:(高-低)*0.191 低,DOTLINE,COLORMAGENTA;

F0.382:(高-低)*0.382 低,DOTLINE,COLORCYAN;

F0.500:(高-低)*0.500 低,DOTLINE,COLORWHITE;

F0.618:(高-低)*0.618 低,DOTLINE,COLORCYAN;

F0.809:(高-低)*0.809 低,DOTLINE,COLORYELLOW;

{黄金分割点位}

波谷:=TROUGHBARS(2,N,1);{波谷起涨位}

波峰:=PEAKBARS(1,N,1);{波峰起跌位}

ZHSJ:=IF(波峰<�波谷,BACKSET(ISLASTBAR,波峰),IF(波谷<�波峰,BACKSET(ISLASTBAR,波谷),0));

DRAWTEXT(波峰<�波谷 AND CROSS(ZHSJ,0.1),高*1.003,'重要阻力')COLORGREEN;

DRAWTEXT(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.191*1.003,' 80.9%'),COLORYELLOW;

DRAWTEXT(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.382*1.003,' 61.8%'),COLORCYAN;

DRAWTEXT(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.500*1.003,' 50.0%'),COLORWHITE;

DRAWTEXT(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.618*1.003,' 38.2%'),COLORGREEN;

DRAWTEXT(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.809*1.003,' 19.1%'),COLORRED;

DRAWTEXT(波峰<�波谷 AND CROSS(ZHSJ,0.1),低*1.003,' 近期低点')COLORRED;

DRAWNUMBER(波峰<�波谷 AND CROSS(ZHSJ,0.1),高,高)COLORGREEN;

DRAWNUMBER(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.809,F0.809)COLORMAGENTA;

DRAWNUMBER(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.618,F0.618)COLORCYAN;

DRAWNUMBER(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.500,F0.500)COLORWHITE;

DRAWNUMBER(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.382,F0.382)COLORCYAN;

DRAWNUMBER(波峰<�波谷 AND CROSS(ZHSJ,0.1),F0.191,F0.191)COLORYELLOW;

DRAWNUMBER(波峰<�波谷 AND CROSS(ZHSJ,0.1),低,低)COLORRED;

DRAWTEXT(波峰>波谷 AND CROSS(ZHSJ,0.1),高*1.003, 重要阻力)COLORGREEN;

DRAWTEXT(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.191*1.003, 19.1%),COLORRED;

DRAWTEXT(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.382*1.003, 38.2%),COLORGREEN;

DRAWTEXT(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.500*1.003, 50.0%),COLORWHITE;

DRAWTEXT(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.618*1.003, 61.8%),COLORCYAN;

DRAWTEXT(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.809*1.003, 80.9%),COLORYELLOW;

DRAWTEXT(波峰>波谷 AND CROSS(ZHSJ,0.1),低*1.003, 近期低点)COLORRED;

DRAWNUMBER(波峰>波谷 AND CROSS(ZHSJ,0.1),高,高)COLORGREEN;

DRAWNUMBER(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.809,F0.809)COLORYELLOW;

DRAWNUMBER(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.618,F0.618)COLORCYAN;

DRAWNUMBER(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.500,F0.500)COLORWHITE;

DRAWNUMBER(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.382,F0.382)COLORCYAN;

DRAWNUMBER(波峰>波谷 AND CROSS(ZHSJ,0.1),F0.191,F0.191)COLORMAGENTA;

DRAWNUMBER(波峰>波谷 AND CROSS(ZHSJ,0.1),低,低)COLORRED;

MA21:MA(CLOSE,21)COLORLIMAGENTA,CROSSDOT;{布林中轨}

{UB:MA21 2*STD(CLOSE,21)COLORLIMAGENTA LINETHICK2;{布林上轨}

{LB:MA21-2*STD(CLOSE,21)COLORLIMAGENTA LINETHICK2;}{布林下轨}

IF(MA21

广告位-