欢迎访问牛股网

牛股网

当前位置:牛股网 > 股票代码 > >

股票代码

把波峰指标在优化一下

发布时间:2020-09-05 17:06 作者:牛股网
编写标准:把波峰指标在优化一下 编写方式:MA1:MA(CLOSE,5); MA2:MA(CLOSE,10); MA3:MA(CLOSE,20); MA4:MA(CLOSE,30); MA5:MA(CLOSE,60);MA6:MA(CLOSE,120); DRAWICON((ZIG(3,5)REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)=REF(ZIG(3,5),2))...

编写标准:把波峰指标在优化一下

编写方式:MA1:MA(CLOSE,5);

MA2:MA(CLOSE,10);

MA3:MA(CLOSE,20);

MA4:MA(CLOSE,30);

MA5:MA(CLOSE,60);MA6:MA(CLOSE,120);

DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1))

AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND

(REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1)

;

DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND

(REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND

(REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);

VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VAR6:=(VAR3 VAR4 VAR5)/3;

VAR7:=EMA(VAR6,5);

ZB:=EMA(EMA(VAR3,5),5)*3,

COLORSTICK;

VAR8:=IF(VAR6<=-20,10,0);

VAR9:=HHV(VAR8,10);

VARA:=IF(VAR9

AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

K:=EMA(VAR7,5)*2, ,

COLORFF00FF;

D:=EMA(K,5), , COLORWHITE;

J:=K*3-D*2,

,COLORYELLOW;

VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND

J>10;

HS:=VOL/CAPITAL*100, , COLORGREEN;

DRAWTEXT(VAR8=10 AND

FILTER(VAR8=10,5),LOW*0.93,'贴近底端')

COLORMAGENTA;

DRAWTEXT(VARA=20,LOW*0.95,'底端')

COLORYELLOW;

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1) 2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1) 2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR11:=VARF<REF(VAR10,1)

AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(VAR11 AND

COUNT(VAR11,30)=1,LOW*0.95,'大资产主题活动'),LINETHICK1,COLORFF00FF;

VAR12:=(HIGH LOW CLOSE)/3;

VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

VAR15:=IF(VAR13>=150

AND VAR13<200 AND VAR14>=150 AND

VAR14<200,10,0);

VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND

VAR14<=-150 AND

VAR14>-200,-10,VAR15);

VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR18:=100-ABS(VAR17);

VAR19:=IF(VAR18<90,VAR18,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR14>=200

AND VAR13>=150,15,IF(VAR14<=-200 AND

VAR13<=-150,-15,VAR16)) 60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND

VAR19<100;

DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'巨额交易量')

COLORWHITE;

{波峰}

TY:=H;

A1:=REF(TY,10)=HHV(TY,2*10 1);

B1:=FILTER(A1,10); C1:=BACKSET(B1,10 1);

HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10 1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10 1);

LD:=FILTER(C2,10);

波峰:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT;

波峰1:=REF(H,BARSLAST(HD))=HHV(H,0);

STICKLINE(H,波峰,波峰,8,0),COLORYELLOW;

STICKLINE(波峰1,波峰,波峰,8,0),COLORRED;

标签
广告位-