欢迎访问牛股网

牛股网

当前位置:牛股网 >股票代码 >

股票代码

将主图公式中出現R底背离的选股公式

发布时间:2020-09-05 17:01 作者:牛股网
编写标准:编写方式:网民求助:请教师将下边主图公式中出現R底背离M底背离K底背离三种状况时各自编写选股公式万分感谢!!!!A:=MA(CLOSE,17)ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));...

编写标准:

编写方式:网民求助:

请教师将下边主图公式中出現“R底背离” “ M底背离” “K底背离”

三种状况时各自 编写选股公式 万分感谢!!!!

A:=MA(CLOSE,17) ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));

B:=MA(CLOSE,17) MA(CLOSE,17)-REF(MA(CLOSE,17),1);

分界点:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,LINETHICK1;

PMA:=分界点;

DD:=分界点<REF(分界点,1);

IF(DD,分界点,DRAWNULL),COLOR00FF00,LINETHICK1;

实际操作线:分界点-(EMA(C,3)-分界点),COLOR00FFFF,LINETHICK1;

S:=(PMA>实际操作线);

IF(S,分界点,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK1;

PM:MA(C,5),COLORFFFFCC,LINETHICK1;

IF(PM>REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK1;

IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;

IF(PM<REF(PM,1),PM,DRAWNULL),COLORFF9900,LINETHICK1;

DRAWTEXT(CROSS(分界点,实际操作线),分界点-0.1,'三底背离');

A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));

B1:=REF(C,A1 1)>C AND REF("MACD.DIF",A1 1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");

DRAWTEXT(B1>0,L-0.02,'M底背离'),COLOR00FFFF;

A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));

B2:=REF(C,A2 1)>C AND REF("KDJ.K",A2 1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");

DRAWTEXT(B2,L-0.10,'K底背离'),COLORFF00FF;

A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));

B3:=REF(C,A3 1)>C AND REF("RSI.RSI1",A3 1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");

DRAWTEXT(B3>0,L-0.18,'R底背离'),COLOR0000FF;

C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));

D1:=REF(C,C1 1)<C AND REF("MACD.DIF",C1 1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");

DRAWTEXT(D1>0,H 0.16,'M顶背离'),COLOR00FF00;

C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));

D2:=REF(C,C2 1)<C AND REF("KDJ.K",C2 1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");

DRAWTEXT(D2>0,H 0.08,'K顶背离'),COLORFFFFCC;

C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));

D3:=REF(C,C3 1)<C AND REF("RSI.RSI1",C3 1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");

DRAWTEXT(D3>0,H 0.04,'R顶背离'),COLORFF9900;

解释以下:

A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));

B3:=REF(C,A3 1)>C AND REF("RSI.RSI1",A3 1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");

R底背离:B3>0;

===============

A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));

B1:=REF(C,A1 1)>C AND REF("MACD.DIF",A1 1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");

M底背离:B1>0;

==================

A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));

B2:=REF(C,A2 1)>C AND REF("KDJ.K",A2 1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");

K底背离:B2;

标签
广告位-