欢迎访问牛股网

牛股网

当前位置:牛股网 >股票代码 >

股票代码

MACD的交易信号

发布时间:2020-09-12 16:57 作者:牛股网
编写标准:MACD指标值,用了好长时间了,很非常好的。但不完美的是信号较为乱!如今请教师给我改下。把原来的信号除掉,改成macd金叉时出現笑容,均线多头排列时出現哭脸。先谢...

编写标准:MACD指标值,用了好长时间了,很非常好的。但不完美的是信号较为乱!

如今请教师给我改下。把原来的信号除掉,改成macd金叉时出現笑容,均线多头排列时出現哭脸。

先谢谢了!

源代码

A:EMA(CLOSE,9)-EMA(CLOSE,18);

B:EMA(A,7),LINETHICK1;

MACD:=2*(A-B);

STICKLINE(MACD>=0,MACD,0,0,0),COLORF00FF0;

STICKLINE(MACD<0,MACD,0,0,0),COLORF00FF0;

STICKLINE(MACD0,0,MACD,0,0 ),COLORFFFF00;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0,0 ),COLORFFFF00;

IF(A<0,A,0),COLORRED,LINETHICK1;

IF(A<0,0,A),COLORRED,LINETHICK1;

IF(AB,B,B),COLORWHITE,LINETHICK1;

DRAWICON(LLV(MACD,4)>0 AND MACDREF(MACD,2) AND REF(MACD,2)>REF(MACD,3),MACD,2);

DRAWICON(HHV(MACD,4)REF(MACD,1) AND REF(MACD,1)

编写方式 :A:EMA(CLOSE,9)-EMA(CLOSE,18);

B:EMA(A,7),LINETHICK1;

MACD:=2*(A-B);

STICKLINE(MACD>=0,MACD,0,0,0),COLORF00FF0;

STICKLINE(MACD<0,MACD,0,0,0),COLORF00FF0;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLORFFFF00;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0,0 ),COLORFFFF00;

IF(A<0,A,0),COLORRED,LINETHICK1;

IF(A<0,0,A),COLORRED,LINETHICK1;

IF(A<B,A,B),COLOR00FF00,LINETHICK1;

IF(A>B,B,B),COLORWHITE,LINETHICK1;

DRAWICON(CROSS(B,A)=1,B,2,1);

DRAWICON(CROSS(A,B)=1,A,1,1);

标签
广告位-